MapGis二次开发基于VC++6.0环境介绍

2016-7-21 14:58:03 0人评论 485次浏览 分类:技术文章

此教程对于使用mapgis基于VC++6.0二次开发的介绍:

1、要完成的工作是将工程中的视图类改为继承CGisView类。具体操作是打开工程中的视图类的两个文件(*View.h、*View.cpp),用Visual C++查找替换功能(Edit菜单下的Replace命令或热键Ctrl+H)分别将这两个文件中的CView字符串全部替换为CGisView,替换完毕,在工程中视图类的定义前面加入#include ,这样就完成了CGisView类的继承。

2、调用CGisView类中的OnDraw(pDC)函数,以完成绘图工作的预先处理。具体操作方法:在视图类的OnDraw(CDC* pDC)函数中加语句CGisView::OnDraw(pDC)。

3、对Visual C++的工作环境进行必要的设置:
第1项(字节)设置:选择Project菜单下的Settings命令,在C/C++页面上,Category一栏选择 Code Generation,并将Struct Member Alignment设定为1 Byte。
第2项(输出目录)设置:把生成的可执行文件输出到MAPGIS动态连接库所在的目录下。选择Project菜单下的Settings命令,在General页面上,Output files一栏,填写mapgis应用程序目录,例如:C:\mapgis67\program
第3项(包含库)设置:设置头文件及库文件的路径。选择Tools菜单下的Options命令,在Directory页面上,在Show directories for:一栏选择include files,在Directories:下面填写MAPGIS二次开发库头文件目录,例如,C:\MAPGIS67\include;然后,在此页面上的Show directories for:一栏再选择library files,在Directories:下面填写MAPGIS二次开发库目录,例如,C:\MAPGIS67\lib。
完成这几步用户就可以进行编译连接,执行,在客户区单击鼠标右键你会发现弹出一个有关MAPGIS操作的快捷菜单。这时用户可以使用CGisView类及其基类中的函数设计自己的基于MAPGIS的图形软件了。
CPrjEditView类(或CGisEditView类)的使用方法和CGisView类的使用方法基本相同。

MAPGIS软件下载 MAPGIS6.7破解

Mapgis6.7教程 地理信息系统实用教程

附件下载

相关资讯

  • Autodesk 3ds Max 2012 安装破解图文教程

    用万地图下载器下载的谷歌地球高程数据,除了可以在电力、水利、通信、石油、国土、农业、林业、环保、环评、矿山、海洋、物探、规划设计、数字城市、道路勘测等GIS行业中使用外,还可以用于在3DS Max中制作三维地形图。Autodesk 3ds Max 2012 安装包请从以下地址下载:http:/…

    2017-11-24 13:53:37
  • 初识地图发布中间件

    如果需要发布海量影像数据快速构建全国离线二维GIS地理信息系统或全球离线三维地球触摸GIS系统,则需要由硬件、软件、数据和GIS平台四部分组成。

    2017-11-14 11:09:17
  • 中间件的项目应用案例 ——《金风科技全球监控中心》

    《水经注地图发布服务中间件》适合所有需要构建全国或全球地图数据服务器并发布海量影像数据的行业,主要包括考古、电力、水利、通信、物流、石油、国土、农业、林业、环保、环评、矿山、海洋、物探、规划设计、数字城市、数字城管、综合应急、智能交通、公共卫生、园林设计、…

    2017-11-13 14:44:15
  • 如何在内网(局域网中)发布OpenLayers地图平台

    这里以中间件作为谷歌地球(GoogleEarth)卫星地图发布引挚,杭州市4到14级谷歌地球卫星地图(WGS84经纬度投影)作为中间件的地图发布数据源,OpenLayers开源平台作为加载中间件发布的卫星影像数据平台,说明如何在内网(局域网)中构建一套基于OpenLayers开发平台的离线WebGIS地理信…

    2017-11-10 10:54:25

共有访客发表了评论 网友评论

验证码: 看不清楚?